D-Link DSL-504 Ethernet Router – Support Forum

Enabling Telnet [D-Link DSL-504 Ethernet Router - 105317]

Hi everyone, I am wondering if anyone can resolve the following problem for me? I want to access my DSL-504 using Telnet, at present I am able to access my dsl504 using the web interface or telnet via the serial cable. I am unable to access it via Telnet and LAN. Does anyone know how to get this working? I have tried the following via the serial cable: > ip portname add telnet 23/tcp > config save > flashfs update > restart I have tried doing the backup configuration and editing snmpinit file and setting the following 2 options: access read abc123 access write xyz345 then restoring the configuration. So i have set these and yet i am still unable to telnet to the router. Any help that anyone can suggest would be very much appreciated. Thanks Freddy
  • rperkin
  • Posts: 2535
  • Join Date: 12 八月 2003
  • Location: UK
Well, it looks like you have studied the information on Trev Roydhouse's site here and in my post addressing the same problem on the similar DSL-604+ here. If you read other posts in that thread, there is something else you could try: editing the 'resolve' file created by the Firmware Upgrade Utility and adding the lines:  portname add telnet 23/tcp  portname add snmp 161/udp then restoring the configuration. Or, as you have access via the console port, try that route for enabling the snmp port. Hope this helps - let us know how you get on
;