Dell Axim X30 312MHz Pocket PC – Support Forum

Booting up [Dell Axim X30 312MHz Pocket PC - 114504]

I purchased a used Dell Axim x30. It won't boot up. I know the battery is good, I used it in another unit. When I first tried to turn it on--nothing. Then I plugged in the cable connection to the desktop PC. The light just stays amber when I try to turn it on. When I power by cable & take the battery out the amber light flashes, put the battery back in, and light goes to a constant amber. If I unplug the cable conection the amber power light flashes, plug it back in & it goes to a constant Amber. Any suggestions? Doggies
  • kathy22
  • Posts: 2
  • Join Date: 11 二月 2007
Hi - did you ever resolve this? I have a similar problem with my X30. I''ve charged the battery, bought a new battery, hard reset it many times but just get a light grey screen. It won''t boot up at all.
Hi--No I never did get it to work. I think I was ripped off. I figured I had nothing to lose, so I took it apart. I think it had been allowed to get a LOT of moisture in it, or had been water soaked. It was terribley corroded all over inside. I have just wrote it off as a bad purchase.
  • kathy22
  • Posts: 2
  • Join Date: 11 二月 2007
Thank you for taking the trouble to reply - sorry you got ripped off. As this is a work''s X30 used by other members of staff - nobody''s going to admit if anything''s happened to it! Luckily I only spent out £7.50 on a new battery. I may sent it to Expansys to see if there''s anything they can do - the unit has been repaired by them previously - may be worth one last chance before we scrap it!
;