EXPANSYS Memory DR25 ExpressCard 34 CF Card Reader – Support Forum

Mac OS drivers do not work [EXPANSYS Memory DR25 ExpressCard 34 CF Card Reader - 151648]

  • aleck
  • Posts: 7
  • Join Date: 7 十一月 2007

I can't get this thing to work under Mac OS Leopard. Drivers install properly, it requires restart and then nothing. It appears in the top menu, but only Power off card option is available, the other two say:

Unknown vendor
IDE Controler

and both are greyed out.

 eXpansys, can you provide a working driver, because now it's a £34 piece of metal and plastic.

  • aleck
  • Posts: 7
  • Join Date: 7 十一月 2007

Any help on this?

The item is unusable as it is. :(

  • meichaun
  • Posts: 5
  • Join Date: 9 十一月 2007

Dear Aleck,

 

Sorry to know you suffer this issue.

 Could you please send me your personal email address to contact?

 I would help you on this issue. By the way, DR25 doesn't need to install any driver under Mac 10.5.

 If you install OS again, you could get DR25 functional properly.

Kindly try it and if you have any problems, please let me know.

Thank you and best regards,

meichuan

  • meichaun
  • Posts: 5
  • Join Date: 9 十一月 2007

Dear Aleck,

Sorry for the problem.

You could install Mac OS again and please don't install DR25 driver because Mac 10.5 Leopard doesn't need the driver to support DR25.

Please try it and DR25 shall get functional well.

Thank you

  • aleck
  • Posts: 7
  • Join Date: 7 十一月 2007

:(

There was no note about that. Reinstalling entire OS just to get rid of it is a bit extreme. Is there any other way to remove the driver?

From what I have seen it installs two .kexts into the system - would removing them restore the funcionality? In the Mac folder on the CD there is a  postuninstall script, which implies some sort of uninstalling is possible.

As for email, can you not see the email address I use to login into these forums?

  • meichaun
  • Posts: 5
  • Join Date: 9 十一月 2007

Dear Aleck,

Sorry, I couldn't find your email to contact.

So far, the only solution is to install Mac OS again but the manufacturer already came out the new driver which would detect users' OS automatically and reminds them not to install the driver again.

DR25 is running in the market before Mac 10.5 is launched, and this issue is solved after the driver is modified.

However, there is no solution for your status except reinstalling OS again. Very sorry about that.

Thank you for understanding.

  • aleck
  • Posts: 7
  • Join Date: 7 十一月 2007

I did Archive and Install with Leopard, but this did not resolve the problem. Still the only available option in the top menu is "Power off card" with other two greyed-out.

 Update: after few re-inserts, a no-name disk appeared in Finder, and it shows the card contents. Thus it appears that it was not fruitless after all. The top menu is still strange though, showing already mentioned options. 

  • meichaun
  • Posts: 5
  • Join Date: 9 十一月 2007

Dear Aleck,

 Could you please give me your email address so that I could have the faster correspondence with you?

 We do hope to solve your problem ASAP.

 Thank you very much

 

  • aleck
  • Posts: 7
  • Join Date: 7 十一月 2007

Try aleksandar DOT vacic AT gmail DOT com

I wrote in the last post that MBP does recognize the card and usually works ok (sometimes requries 2-3 inserts). If you think there are more things to try, please send them to me.

 -- 

AV

  • Ashmanil
  • Posts: 1
  • Join Date: 1 十二月 2007

Hi guys,

 I'm having almost exactly the same problem. Same thing: Installed card and driver in Tiger, then did an upgrade install to Leopard. Now I AM able to see the Expresscard and the CF-card but my system crashes pretty soon after accessing the card :-( I also get the same strange menu entry.

 And I absolutely DO NOT want to reinstall.

 Any solution? You can mail me at ashmanil.10.babbly@spamgourmet.com

  • aleck
  • Posts: 7
  • Join Date: 7 十一月 2007
Ashmanil, I don't think you have any other option. I even extracted the file that driver is changing from the LEopard instal disk, replaced, executed postuninstall script, nothign worked except the Archive and install option. That worked rather well - all things were preserved except the 10.5.1 update which I repeated.

i have same program. 

can't work on mac os 10.5 

;